Cabecera-v2-web.jpg

Vulnerabilidad de riesgo alto en Squid permitiría la ejecución remota de código


Recientemente se ha descubierto una vulnerabilidad en Squid, la misma ha sido identificada y catalogada como CVE-2020-11945 de riesgo alto. Este fallo permitiría a un atacante remoto realizar un ataque de replay y ejecutar código remoto o acceder a información confidencial, interfiriendo en el proceso de autenticación de HTTP Digest, un mecanismo de autenticación basado en hashes criptográficos que evitan que la contraseña de los usuarios sea enviada en texto claro.

Este fallo afecta a las siguientes versiones de Squid:

  • Squid 2.x - 2.7.STABLE9;
  • Squid 3.x - 3.5.28;
  • Squid 4.x - 4.10;
  • Squid 5.x - 5.0.1.

Detalles Técnicos.

Este fallo se da debido a un desbordamiento de números enteros cuando es utilizada la reserva de la memoria (memory spooling), permitiendo a un atacante remoto interceptar el proceso de autenticación, realizar un ataque replay, y acceder a información confidencial de la red mediante el envío de credenciales supuestamente válidas, esta información podría ser utilizada para la posterior explotación del sistema.

Por otro lado, cuando el pooling de la memoria es desactivado, podría permitir al atacante la ejecución remota de código a través del "free’d nonce credentials".

Recomendaciones.

  • Actualizar Squid a las versiones 4.11 o 5.0.2, dichas versiones han abordado esta vulnerabilidad.
  • En caso de no ser posible la actualización, como medida alternativa de mitigación, se recomienda eliminar o comentar el parametro "auth_param digest" ubicado en el archivo squid.conf.

Referencias.


pie.png

CERT-PY | Centro de Respuestas a Incidentes Cibernéticos
Ministerio de Tencnologí­as de la Información y Comunicación (MITIC)

Avda. Gral. Santos c/ Concordia | Telefono: (595 21) 217-9000
República del Paraguay

80x15.png

Versión del Template 1.11