Cabecera-v2-web.jpg

Vulnerabilidad crítica de XSS permanente en la plataforma Moodle


moodle.png

Moodle es una plataforma de aprendizaje diseñada para proporcionarle a educadores, administradores y estudiantes un sistema integrado único y robusto para crear ambientes de aprendizaje personalizados. En términos más técnicos, es un sistema web dinámico creado para gestionar entornos de enseñanza virtual, basado en tecnología PHP y bases de datos MySQL.
El primer punto fuerte de Moodle es que es un software libre que se distribuye bajo la licencia GPL (General Public License). Esto significa que cualquier persona o institución puede hacer uso de él y adaptarlo a sus necesidades, además cuenta con muchas más ventajas:

  • Intuitiva y fácil de usar,
  • Flexible y personalizable,
  • Escalable a cualquier tamaño,
  • Robusta y privada.

Esta plataforma de aprendizaje, es una de la más utilizadas en nuestro país por las universidades, colegios, centros de capacitaciones, etc.

¿Qué pasó?

Recientemente un investigador ha detectado una vulnerabilidad crítica en Moodle que afecta a la versión 3.8. Esta falla tiene reservado el identificador CVE-2020-1691 y se da debido a la sanitización inadecuada antes de actualizar el resumen de los mensajes, dando así lugar a una vulnerabilidad conocida como XSS (cross site scripting) almacenado, que puede permitir a un atacante remoto inyectar código JavaScript malicioso en páginas web vulnerables, quedando almacenado en el servidor.

La explotación exitosa de esta vulnerabilidad puede permitir que un atacante remoto robe información potencialmente confidencial, cambie la apariencia de la página web, redirija al usuario a sitios que contengan malware, realice ataques de phishing y drive-by-download o también conocida como descarga involuntaria de software, entre otros ataques.

Recomendaciones:

  • Actualizar Moodle a la versión 3.8.1. disponibles en el sitio web del fabricante.
  • Por otra parte, si por algún motivo no es posible actualizar la plataforma Moodle, para prevenir la explotación se puede deshabilitar el sistema de mensajería. hasta tanto se pueda aplicar la actualización que corrige la vulnerabilidad.
  • Instalar un WAF (Web Application Firewall) que filtre las peticiones HTTP que contengan código malicioso.

Referencias:



pie.png

CERT-PY | Centro de Respuestas a Incidentes Cibernéticos
Ministerio de Tencnologí­as de la Información y Comunicación (MITIC)

Avda. Gral. Santos c/ Concordia | Telefono: (595 21) 217-9000
República del Paraguay

80x15.png

Versión del Template 1.11