Cabecera-v2-web.jpg
xhamster xvideos pornhub redtube xxx thumbzilla

Vulnerabilidades críticas en el software del DCNM de CISCO


c2.png

DCNM (Data Center Network Manager) es un sistema de administración de red para todos los sistemas NX-OS que utilizan el hardware Nexus de Cisco. Se encarga de solucionar problemas, detectar errores de configuración, etc. Por lo que es una parte importante para las organizaciones que utilizan Nexus switches.

Para más información sobre Cisco DCNM puede hacer click aquí

¿Qué pasó?

Cisco ha dado a conocer una serie de vulnerabilidades que afectan al DCNM (Data Center Network Manager) en versiones anteriores a 11.3(1), entre las vulnerabilidades se encuentran: la ejecución remota de código, violación de datos y omisión de autenticación.

Los CVE asociados a estas vulnerabilidades son: CVE-2019-15984, CVE-2019-15985, CVE-2019-15980, CVE-2019-15981, CVE-2019-15982, CVE-2019-15978, CVE-2019-15979, CVE-2019-15977, CVE-2019-15976 y CVE-2019-15975. Cisco ha mencionado que, las vulnerabilidades son independientes entre sí y que la explotación de una no es necesaria para explotar a otra.

A continuación se describen las vulnerabilidades más críticas:

  • Vulnerabilidad de omisión de autenticación de API REST: La explotación de esta vulnerabilidad permitiría a un atacante remoto evadir la autenticación; esta falla existe debido a una clave de cifrado estático compartida.
  • Vulnerabilidad de omisión de la API SOAP: La explotación de esta vulnerabilidad podría permitir a un atacante realizar acciones arbitrarias a través de la API SOAP con privilegios administrativos.
  • Vulnerabilidad de omisión de autenticación: Esta vulnerabilidad se da por una debilidad en la interfaz de administración web de Cisco DCNM, el cual permitiría a un atacante remoto omitir el paso de autenticación.
  • Vulnerabilidad de inyección SQL de API REST: La explotación de esta vulnerabilidad permitiría que un atacante remoto autenticado con privilegios administrativos ejecute comandos SQL arbitrarios.
  • Vulnerabilidad de inyección de comandos API REST: Esta vulnerabilidad se da por la falla de seguridad en la API REST de Cisco DCNM, el cual podría permitir que un atacante autenticado con privilegios de administrador en la aplicación de DCNM inyecte comandos arbitrarios en el sistema operativo subyacente.

Cisco informa que, ya corrigió estas vulnerabilidades en las versiones 11.3 (1) de Cisco DCNM en Windows, Linux y plataformas de dispositivos virtuales.

Recomendaciones:

Siempre es recomendable mantener el software a la última versión estable disponible, en este caso se solucionan las vulnerabilidades con la versión Cisco DCNM 11.3 (1).

Referencias:


pie.png

CERT-PY | Centro de Respuestas a Incidentes Cibernéticos
Ministerio de Tencnologí­as de la Información y Comunicación (MITIC)

Avda. Gral. Santos c/ Concordia | Telefono: (595 21) 217-9000
República del Paraguay

80x15.png

Versión del Template 1.11